Solved

How to stop time sheets being auto-approved?

  • 24 August 2021
  • 4 replies
  • 82 views

Userlevel 1
Badge

Hi Personio Community!

 

My team are using attendance tracking for timesheets for each day. I have set it up so that they input their project against each day. 

 

I have also set up the default approval step for attendance submissions to go to me (selected as a Specific Employee). 

 

However, whenever they complete a timesheet and save the entry it shows as approved rather than pending and I never receive an approval request. 

 

Any ideas on how to stop this automation and allow me to approve the submissions? 

 

Thank you!

icon

Solved by CécileM 24 August 2021, 14:43

View original

4 replies

Userlevel 2
Badge +3

Hello and welcome to the Personio Community, @BenCarterBrightNetwork !

I hope this message finds you well.

In order for an approval process to be triggered, you need to go to Settings>Employee Roles, choose the role that is impacted by this, then go to Access Rights>Attendance Data and set the rights to Propose Own.

If you put Edit Own, that will mean employees will be able to fill in their times without approval requests. It will just looked as approved automatically. The Propose right will make sure that you receive the notifications and you can accept the requests. In that situation, the Pending status will appear.

Does this help you? Please let me know if it still does not work!

Kindest regards,

Cécile.

Userlevel 1
Badge

Thanks Cecile!

 

I have made that fix and will see how the submissions go on Friday. 

 

Thank you!

Userlevel 2
Badge +1

Hi @BenCarterBrightNetwork,

I hope you had a lovely weekend!

Would you be so kind as to let us know did the solution given above helped you to solve the issue in your Personio account?

Kind regards,

Dino

Userlevel 1
Badge

Hi @Dino Hadzikadunic,

 

Yes - I have just marked @CécileM as the best answer. It worked exactly to plan.

 

Thank you!

Your reply