Subcompany visibility

  • 9 January 2023
  • 2 replies

Userlevel 1

Hi Personio Community!


I need your support😉.


We have activated a subsidiary and would like to manage a reduced visibility of the employees entered (ex: not see main company’s employees).

I tried following the help centre info but can't set it up.


Can anyone help us?



Best answer by ConorCunningham 9 January 2023, 11:59

View original

2 replies

Userlevel 5
Badge +7

Hey @AleWeLearn 

Welcome to the Personio Community 😃

So first I would navigate to Settings > Employee Roles > All Employees role > Access rights > Personal data > Public profile. You will need to ensure that this All option for View has not been check-marked. If you have this switched on, it means every employee will be able to see the employee profile for all other employees. We want to only allow employees within one subcompany to view their own subcompany’s employee profiles I take it from your question.


Then I would recommend creating an employee role and adding all the employees from this subcompany into this as members. Next you will navigate to Access rights within this employee role > Personal data > Public profile.

Within here you will choose the Custom option from the View option and set up the filter Subcompany equals Own. What this will do is only allow these employees to view other employees profiles, that are within their own subcompany.


As we have turned off the View All option for the Public Profile within the All Employees role, we will need to repeat the step above for employees within the main company. Again I would create an employee role, add the other remaining employees from the main company as members. Navigate to the Public Profile access right once again and grant them whichever view access you desire. 

This should now mean that the main company employees have had their access rights re-instated within this employee role and should now able to view other employee profiles as set up. 

I will be happy to assist you further on this, if you run into any difficulties.




Userlevel 1

Hi Conor,

Thank you for the information!
All settled😃



Your reply