Recruiting "Something went wrong, please try again." error message whenever I try to save or edit a job post

  • 7 February 2024
  • 1 reply

Hi everyone! 


Currently, whenever I try to save a job post as a draft I receive the following error message "Something went wrong, please try again." 

Also just to check it was not user error on my side, I have tried to edit roles that are already posted and the same error message appears. 

Has anyone ever experience something similar and if so is there a quick fix?

Thanks in advance for any suggestions! 


Best answer by International Support Team 9 February 2024, 13:43

View original

1 reply

Userlevel 6

Hey @AndreaV 

Welcome to the Personio Community, we are thrilled to see you here 🎊 🥳. I am happy to support you with your inquiry.

This sounds to me like a bug, therefore in order to highlight this to the Product Team kindly have your Account Owner reach out to our support team via Find Answers.

Once they receive your request, investigations can be made to confirm this and move onto next steps.

If there is anything else I can help with, please let me know.

Best regards, 


Your reply